Can't Login in the game because of the absence of a KEY

Anything and everything related to BscotchID.

I tried to login but I couldn't the 1st time so I tried to change my password.
Password Change Done,
But now I have a problem because the Game (Crashlands) login doesn't have certain keyboard characters like / or ? or .
which of course I used in my password...
So I tried to change my password again but...
The game refuses to give me the email to change password.
Tried the web version, but the link that was clicking on it, it thinks I already reset the password "Keep it secret, Keep it safe".
As you can see I can login into the forums here. But I can't login into the game...

What am I supposed to do now? Hope can solve this problem before the New Year...

User avatar
Posts: 2

Paging @bscotchAdam!

User avatar
Posts: 1371
Location: St. Louis, Missouri, USA

When you hit SHIFT in-game, don't those characters appear?

In any event, if there is something wonky happening with the in-game password reset, you can go to instead. Note that one request makes the prior ones not work, and a single request can only be used once (for security).

It's also possible that your browser has cached the "Password changed" version of the page so it's not showing you what you need. Open the same link in the "incognito mode" of your browser to get around that.

User avatar
Posts: 1722
Location: Dallas, TX USA

When I press SHIFT, only some characters are there but not every one...

But I managed to change Password again so...
Thanks so much! Hurray! :D

User avatar
Posts: 2

Return to BscotchID

Who is online

Users browsing this forum: No registered users and 2 guests