[Resolved] Garaams Freedom Quest Bugged - Can't Progress

All about playing the game. Tips, tricks, and how to resolve problems. For fans of the game, do not treat this like a support system!
The mini dungeon containing the key to free Garaam has spawned next to Baarnapol over a body of water. One of the floor tiles for the only single block corridor leading in has a fishing spot underneath it and will not allow Flux to pass through, even if I fish through the floor until it is used up.

This means I am unable to finish the quest. The only thing I can think of to bypass this problem might be a wings buff but there isn't one nearby.

This appears to be a bug, please advise if there is a way for me to progress.


I have tried to progress with the follow up Spy quest to steal the Beakler, it turns out I need the security key from the above mentioned bugged dungeon for that as well, so this bug completely blocks progression. Very frustrating.

Update 2:

I can proceed with the main quest line after all, just not the quests from the white quadropus spy at Grammy house.

Here are the screenshots

https://www.dropbox.com/s/bmuh7ew4q9lkr ... 7.png?dl=0

https://www.dropbox.com/s/i9d8dsj703gpj ... 5.png?dl=0

https://www.dropbox.com/s/vmjo5fauv4y5k ... 1.png?dl=0

Apologies for the earlier double post.

Thank you.
Last edited by Maeglus on 24 Jan 2016 23:43, edited 1 time in total.

User avatar
Posts: 3

@Maeglus Heyo! We can't find a problem that matches what you've described. Can you post a screenshot?

User avatar
Posts: 1722
Location: Dallas, TX USA

@Maeglus deleted your second topic because we don't need any duplicates and it's definitely some unlucky Map Generation bug. At least it seems to be.

Please just take a screenshot and post it here so the bros can actually help you! :)

User avatar
Posts: 1831
Location: Bordeaux, France

Updated with screenshots, apologies again for the double post and thank you for the prompt response, also congratulations on a wonderful game.

User avatar
Posts: 3

Oh, I see what's happened. The corridor of the dungeon has been built over a fishing spot. An unfortunate spawn that shouldn't happen, but every now and then things do bork.

The only thing I can suggest is finding a flight buff somewhere else and then teleporting there and flying through the corridor, which shouldn't be a problem if you can find a flight buff anywhere. They do last a couple of minutes though, so it should be fine to teleport back there with two telepads so close to it.

@bscotchseth might be able to look into the rules in the game and see if that's a rare once-off or if something was missed and needs updating, but I don't know if it can be retroactively applied to your particular game version. Sorry about that. Seth can give you a better answer, but for the short term a flight buff seems like the best idea to me.

User avatar
Posts: 939
Location: #1 Australian Fan

I have run into this same issue. Whenever I talk to the now free Barbraan, he says "Take my hand!", but then nothing happens:


My quest dialogue just says "If you can find that key and get me out of here, I'll be most grateful!":


Finally, I still have a quest indicator for Barbraan's Key even though I have already used it to free him:


Edit: Err, I may have misread the original post. I have run into a quest sequence break issue. Should I put this into a separate post?

User avatar
Posts: 2

Might be a bug. But before that, have you exited the game (completely, force close the app if necessary, or completely reboot your device to clear it out comepletely), then rerun it and try to resync your game? Maybe the deborkifier is on lunch break, it usually runs at startup and double checks your progress. It'll go through and see that you've done some tasks and should put you back on the right track.

If you're still having trouble after that let us know, and we'll get Seth on to it.

User avatar
Posts: 939
Location: #1 Australian Fan

I rebooted my machine, attached my guest save to this Butterscotch account, and cloud synced the save.

Somewhere along the lines the issue got resolved; thanks :)

User avatar
Posts: 2

I've tried the flight buff suggestion, sadly this doesn't work, I still can't get past the fishing spot under the floor tile.

User avatar
Posts: 3

Return to Crashlands Gameplay

Who is online

Users browsing this forum: No registered users and 1 guest