[BIG BUG] Crash after death. Corrupted save

All about playing the game. Tips, tricks, and how to resolve problems. For fans of the game, do not treat this like a support system!
Died in the high ground area a few times and during one of my last deaths i got a crash message. Clicked abort and then started up again and during the save load I kept getting this message.
___________________________________________
############################################################################################
ERROR in
action number 1
of Step Event0
for object o_loader:

Illegal argument type
at gml_Script_load_binary_biome_from_file
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_load_binary_biome_from_file (line 0)
gml_Script_load_progress_cl
gml_Object_o_loader_Step_0


I also get a few other different ones.


___________________________________________
############################################################################################
ERROR in
action number 1
of Other Event: User Defined 2
for object o_character:

Illegal Buffer Index
at gml_Script_save_progress_cl
############################################################################################
--------------------------------------------------------------------------------------------
stack frame is
gml_Script_save_progress_cl (line 0)
gml_Object_o_character_Other_12


Save is in the cloud.

User avatar
 
Posts: 2

Whoops! @bscotchseth - big bug for you.

User avatar
 
Posts: 939
Location: #1 Australian Fan

Does it let you continue to play, or are you stuck?

User avatar
 
Posts: 1371
Location: St. Louis, Missouri, USA

If I keep hitting ignore it lets me play but the UI/resolution is wrong. Mind you there are around 10-15 windows I have to click ignore as the save is trying to load to get to play. Looked like 10 different messages. And new ones popping up during gameplay.

I have the playable area in the upper 2/3 left of the screen corner and the rest is grey/white as if the you tried to play a 600x800 game in a larger window. Also the mouse isn't registering where i want but its proportional to the screen, so where i click on my resolution shows up in the smaller resolution where it would be scaled.

User avatar
 
Posts: 2

That sounds... impressively broken. We're working on a way for Seth to load your file so he can try to debug it.

User avatar
 
Posts: 1722
Location: Dallas, TX USA

I was able to pull this save down and play it with no issues. Try a reinstall!

User avatar
 
Posts: 1371
Location: St. Louis, Missouri, USA


Return to Crashlands Gameplay

Who is online

Users browsing this forum: No registered users and 1 guest