firehouse ruin post 347

All about Questing. Tips, tricks, and how to resolve problems. Likely contains spoilers. For fans of the game, do not treat this like a support system!
I've collected the hologram and killed the crabs in this mission, but the hologram went into my build inventory and jak won't llet me finish the quest. Any tips? What have I done wrong?

User avatar
Posts: 2

Have you tried putting the hologram back down and picking it back up? Might have to do this in the location you got it from for the quest to trigger to the next step, but most retrieval quests just require the item be in your inventory when handing it over anyway (and I'm pretty sure that's one of those quests),

User avatar
Posts: 939
Location: #1 Australian Fan

I tried that, still didn't work for me. Jak's being STUBBORN. :x

User avatar
Posts: 39
Location: 'Stralia

Have you tried reinstalling just in case it's the game and not the save? The deborkifier should be able to fix this if it's not I'd say do a fresh install of the game but MAKE SURE everything is backed up.

User avatar
Posts: 768
Location: New Jersey

Hi, I have tried using the suggested methods to rectify this quest (Yes, including deborkifier). But to no avail. I have even tried installing in another HP or tab but once it loads up from the Cloud file, Jak still won't talk to me.... :(

I have tried placing the Hologram back at ruin post 347 But it prompts me an error that it needs to be place on a floor. I place the flooring first and then put the Hologram on it and pick it up again But the quest still won't change to Finished. I still have the Hologram sitting in my inventory.

Could this quest had Bugged out because I took the hologram without killing the 2 crabs that was guarding it first? Please help/adv me what else to do. I do believe that this is a in game Bug. TQ

User avatar
Posts: 4

If you're not on the beta version, you might want to try it since the deborkifier got a lot of good modifications (it allowed me to finish a quest I did bork).
If you're already using the beta/QoL version, this may be a huge problem and then we may have to ask @bscotchseth

User avatar
Posts: 1831
Location: Bordeaux, France

Hi, Thanks for replying.

Still can't hand in the quest, reinstall the game 2 times, Jak still stubborn. :( Bought this game on the Feb 6, 2016 using Android version not sure about the beta/QoL version though.

I just wanna hand in the quest and complete the game in order before I attempt Hewgodooko for the last time.

Will file this officially as a Bug under Crashlands Gameplay section. Just got the Megagong and chillout a few days hoping someone can fix this bug.
Last edited by Etrusan on 05 Apr 2016 16:43, edited 1 time in total.
Reason: Don't double post the same issue.

User avatar
Posts: 4

Hey @bscotchseth / @bscotchAdam - any ideas? Can you help out @mattazon here?

User avatar
Posts: 939
Location: #1 Australian Fan

I'm not familiar enough with the quest! Sone screenshots of the dialog would be super helpful.

@bscotchsam is more likely to know the answer.

User avatar
Posts: 1722
Location: Dallas, TX USA

Hi, I wish I can insert the image but I dunno how to do it via URL. I'm sorry.

If I type out the content of the quest, would it help?
Location: G.H.Q , Tundra
Quest Giver: Jak
Quest Name: Firehouse Ruinpost 347

Chat Log
Flux: Unless what?
Jak: Unless he was building something to install there. Like a permanent incinerator. No use dallying till we have more info. Go to Ruinpost 347 and retrieve the Hologram. It might have the info we need.

Quest Objective: To retrieve the Hologram at Ruinpost 347 and return to Jak.

Couldn't the GameMaster just load my Cloud file to validate the Bug?

Anyways, hope someone can help me out. TQ

User avatar
Posts: 4


Return to Crashlands Quests

Who is online

Users browsing this forum: No registered users and 2 guests